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Introduction 
 

The SOTER(Global and National Soils and Terrain Digital Database)  programme is a joint 
initiative of ISRIC (International Soil Reference and Information Centre), IUSS (International 
Union of Soil Sciences), FAO (Food and Agriculture Organization of the United Nations) and 
UNEP( United Nations Environment Programme). 
The development of SOTER map units are based on topographical and lithological information. 
The first level of the development of these SOTER units is the ‘terrain’ unit. 
This development is usually based on the “expert” interpretation that relies on ancillary data sources 
and first hand knowledge of the scientists involved  in the project . This expert interpretation may 
be somewhat subjective. With the increasing capabilities of GIS technology and availability of 
digital spatial data, new approaches can be used for the characterization process. 
Digital Elevation Models (DEM) make elevation data available for spatial analysis using GIS. 
Methods are presented how DEM-derived terrain classes can be made. 
 

Dem uncertainty 
 

DEMs can be produced from different sources such as: 
 Aerial photography 
 Elevation contours from maps (termed the "contour-to-grid" process)  
 Satellite data 
 Laser altimetry 
 Radar (Interferometry) 

Elevation data represented in digital format is called a Digital Elevation Model. 
So DEMs are models of elevation. 
Digital elevation data is often effected by errors due to random sampling error and excessive 
interpolation. The errors in DEMs propagates itself into error in all parameters derived from the 
DEM. The lack of knowledge about the reliability of the elevation measurement and its 
representation of the truth is referred to as uncertainty.  
The exact nature and location of errors in elevation data cannot be precisely determined. 
Several methodologies has been developed to simulate the effect of uncertainty on DEMs and the 
derived parameters such as slope, aspect, relief, etc. 
(especially the Monte Carlo simulation is well known) 
There are three types of error: 
1. Blunders 
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 Vertical errors associated with the data collection process and are generally identified 
and removed prior to release the data. 

2. Systematic errors 
  Results of procedures used in the DEM generating process and can cause bias or 

artefacts in the final DEM product. When the cause is known, the systematic error 
can be eliminated or reduced. 

3. Random errors 
  Remain in the data after blunders and systematic errors are removed. 
The users must be aware of the problems of uncertainty in DEM data. 
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Software 
WinZip 
ArcView 3.2(a) 
ArcView Spatial Analyst Extension 
ArcView 3D Analyst extension (Only for the visualization techniques) 
 
 
 
 
 

Retrieving the DEM from the web 
 
De GTOTO30 data set was developed by the U.S. Geological Survey’s EROS Data Center. 
The data set covers an area that ranges between 90 degrees north to 90 degrees south latitude an 
between 180 degrees west to 180 degrees east longitude. 
The horizontal grid spacing is 30 arc-seconds (0.008333 degrees or approximately 1 kilometer.) 
The coordinate system is decimal degrees and longitude referenced to WGS84. 
The vertical units represent elevation in meters above sealevel. (from –407 to 8752 meters) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
Tile e020s10 (Zimbabwe included) 
 
Download website: 
http://edcdaac.usgs.gov/gtopo30/e020s10.html
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Oceans have been masked as “no data” and have a value of –9999 
The download consists of a compressed e020s10.tar.gz file. 
Decompress this file with WinZip into the desired folder.(f.i. the working directory of ArcView) 
This folder contains 8 folders with different extensions. 
Rename the e020s10.dem to e020s10.bil (Band Interleaved by Line)  
This file can be imported in Arcview. 
 
 

Retrieving and manipulating the DEM in ArcView 
 
 
Start Arcview  and  under File►Extensions make sure the Spatial Analyst  is loaded. 
Set the Working Directory under File to your folder. 
Open a new View and under View►Properties set the Map Units to meters and the Distance Units 
to kilometers. 
Projections Properties ►Category:Projections of a Hemisphere Type:Lambert Equal-Area 
Azimuthal (Equatorial). Select Custum and type +20 for the Central Meridian and +5 for the 
Reference Latitude. 
 
 
Add the e020s10.bil image file to the View as Image Data Source. 
Make the theme active and display. 
Convert the image to grid by choosing Theme►Convert to Grid, put it in your folder and give it a 
name. 
Because a grid cannot be projected in theView,  it first must be projected in ArcInfo. 
Statements: 
projectcover inputfile outputfile 
input 
projection geographic 
units dd 
datum WGS84 
spheroid WGS84 
parameters 
output 
projection Lambert Azimuthal Equal Area 
units meters 
longitude center: 20 00 00 
latitude center :   05 00 00   
 
An alternative way to project the data, if you don’t possess ArcInfo or ArcGis is  to download the 
ArcView extension patch analist.avx from the web and put it in the directory 
\esri\av_gis30\arcview\ext32. 
Retrieve the projected gridfile into Arcview and give it the name Elevgrid. 
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Browse to the esri\esridata\world folder and add the cntr98.shp to your View as a Feature Data 
Source. Make it active and display. 
With “Select Feature” select Zimbabwe and choose Theme►Create buffers.(Only for the selected 
features) 
Now you are creating a buffer of 50 km only outside the polygons. 
Theme►Convert to Shapefile, put it in your folder and name it Zimbuf. Remove the cntr98 shape 
file from the View. 
. 

 
 
 
 
Add your Zimbabwe reference (Esri) shape file to the projected View. 
Make Zimbuf.shp active: Theme►Convert to Grid . In the dialog box fill in for the -Output Grid 
Extent-: Same As Zimbuf.shp, for the -Output Grid Cell Size-: Same As Elevgrid►OK 
Accept the -Pick field for cell values-►OK and add the theme to the View under the name Zimgrid. 
 
The calculations are performed only for the desired area (Zimgrid) : 
  Analyses ► Properties  
-Analyses Extent- Same As Zimgrid 
-Analysis Cell Size- Same As Elevgrid (1000m) 
-Analyses Mask- No Mask Set 
 
Manipulating the grid values in the Grid theme: 
Analyses►Map Calculator:  
([Elevgrid] >=32768).con([Elevgrid]-65536,[Elevgrid]) 
 
In this formula 32768 represents 215  and 65536 represents 216. 
In the GTOPO30 DEM, 1 bit is used for the sign and 15 bits for the number. 
This means 215 is the maximum value that can be presented. 
Arcview interprets the integer data as unsigned and uses all 16 bits for the number. 
The values are in the range of 0 – 65536. 
The outputgrid is Mapcalculation 1 
 
As earlier mentioned, GTOPO datafiles use –9999 for the ocean. 
These values need to be changed to 0. 
Analyses►Map Calculator: 
([Map Calculation 1]=-9999).setnull([Map Calculation 1]) 
The outputgrid is Mapcalculation 2 
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Double Click on theme Map Calculations 2 
-Classify-  Number of classes: 5 

      Round values at: d 
 
Make classes in the field “Value” of  0-200; 200-300; 300-400; 400-600; 600-1000; 1000-1500; 
1500-3000; 3000-5000; >5000  Color Ramps: Terrain Elevation #3 
Save the legend as elevation.avl 
 
With Map Calculation 2 active: Theme ► Properties Rename the Theme Name to Elevation 
 
This elevation grid is the base for further calculations.  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Visualization and analysing techniques 
 
To create a Profile Graph: 
 
View ►New Themes 
In the New Theme dialog box fill choose for the Feature type “Line”; OK and accept the File Name 
Select the “Draw Line” button and draw a line in the map of the zone to be analysed. 
With the line selected:  
Theme ►Convert to 3D Shape file  
In the dialogbox : Get Z values from: Surface; OK 
Choose theme to use as surface: Elevation 
Sample distance on grid: 1000; OK 
Accept the file name and add the 3D shapefile as theme to the view. 
Make the line somewhat thicker and make it black. 
View ► Layout  
Modify the layout and put the elevation map at the top. 
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Choose the “Profile Graph” button and draw a box beneath the elevation map. 
 
To create Hillshade grid: 
a. Surface ► Compute Hillshade     
Or with the Map Calculator: 
b. [Elevation].Hillshade(315,45,2) 
Where 315 is the value for the azimuth (0-360); 45 the value for the altitude (0-90)  
2 is a zfactor. Nil for no zfactor. 
(a disadvantage of method a is that there is not a possibility for giving it a zfactor)  
With the elevation theme active doubleclick  this theme and in the Legend Editor open the 
Advanced button and choose Hillshade of Elevation under Brightness Theme and accept the 
Minimum/Maximum  Cell Brightness (20/80); OK 
Now the elevation theme gives a relief. 
                                Hillshade 
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The Moving window  
 
 

 =  moving window 
 
 =  area that is affected by edge effects. 
  When the processing cell is in this area, part of the moving window has no data 

    when calculations are performed on the input theme. 
   Therefore, the output values located in the gray area are based on incomplete 

  information. This is the main reason to create a buffer around Zimbabwe to enlarge 
   the analysis extent. 
 

 

 

  = Processing cell 
 

   
                              
                              
                              
                              
                              
                              
                              
                              
                              
                              
                              
                              
                              
                              
                              
                              
                              
                              
 
The moving window is used on raster data to perform neighborhood analyses such as mean, sum, 
minimun, maximum, median, range, standard deviation, minority, majority and variety. 
Calculations are performed in the window (yellow) and in the new output grid this value is stored at 
the place of the processing cell. The window is then moved one cell position and calculations are 
repeated until the entire grid has been processed. 
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The moving window is a square window and has a dimension of 5 x 5 cells. 
The window does not necessarily have to be square. It can be circular or defined as a rectangle 
A disadvantage of the square or rectangle window is that the diagonal neighborhood cells have not 
the same distance from the processing cell. 
A circle seems more appropriate than a square because the boundary of a circle will always be of 
equal distance to the focal point. (the processing cell) 
 

   
  The distance from the centre of the red cell to the yellow one = √ 2 = 1.41 km in a 1 km grid 

 
Slope 

 
Many different algorithms exist to compute slope from an elevation grid. Most systems pass a 3x3 
moving window over a grid where the slope for the center cell is computed. 
ArcView computes slope using a method called “Kings Case” that incorporates all surrounding 
eight cells where the slope for the centre cell E is computed from the surrounding cells 
A, B, C, D, F, G, H and I (Burrough and McDonnell,1998; ESRI, 1998) 
 

 A  B  C 

 D  E  F 

 G  H  I 
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To derive slope: 
 
Analyses ► Map Calculator: 
[Elevation].Slope(2.5,TRUE) 
Evaluate 
The factor 2.5 has been chosen because the slope in a 1 km DEM is in reality 2.5 times of this 
value. One has approved this by comparing the slope values with higher resolution DEM’s. 
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Double click the theme and make 4 classes of respectively 0-2; 2-8; 8-30 and >30 % slope 
Round values at: did 
Rename the theme name to “slope” under Theme Properties. 
Analyses ► Map Calculator: 
Neighborhood statistics: Statistic: Mean Neighborhood: Rectangle Width: 3 Height: 3 Units :Cell 
Neighborhood statistics: Statistic: Mean Neighborhood: Rectangle Width: 5 Height: 5 Units :Cell 
Neighborhood statistics: Statistic: Mean Neighborhood: Rectangle Width: 7 Height: 7 Units :Cell 
 
 

 
Relief 

 
The 5 x 5 moving window is used to derive the maximum and the minimum elevations. 
The Relief = ElevationMAX  - ElevationMIN
 
There are two ways to calculate the index: 
1. Analysis ► Map Calculator (this example only uses the 5 x 5 moving window) 
([Elevation].Focalstats(#Grid_statype_MAX,NbrHood.MakeRectangle(5,5,false)- 
([Elevation].Focalstats(#Grid_statype_MIN,NbrHood.MakeRectangle(5,5,false) 
Evaluate 
The mean of the Relief: 
([Reliefgrid].Focalstats(#Grid_statype_MEAN,NbrHood.MakeRectangle(5,5,false) 
Evaluate 
The other way is straight from the Analysis menu: 
2. With the elevation theme active: 
Neighborhood statistiscs: Statistic: MAX Neighborhood: Rectangle Width: 3 Height: 3 Units :Cell 
Neighborhood statistiscs: Statistic: MAX Neighborhood: Rectangle Width: 5 Height: 5 Units :Cell 
Neighborhood statistiscs: Statistic: MAX Neighborhood: Rectangle Width: 7 Height: 7 Units :Cell 
Respectively: 
Neighborhood statistiscs: Statistic: MAX Neighborhood: Rectangle Width: 3 Height: 3 Units :Cell 
Neighborhood statistiscs: Statistic: MAX Neighborhood: Rectangle Width: 5 Height: 5 Units :Cell 
Neighborhood statistiscs: Statistic: MAX Neighborhood: Rectangle Width: 7 Height: 7 Units :Cell 
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Analyses ► 
Map Calculator: 
([NbrMax of Elevation] – [NbrMin of Elevation]) 
Evaluate 
The mean of the relief: 
Analyses ► Map Calculator: 
Neighborhood statistics: Statistic: Mean Neighborhood: Rectangle Width: 3 Height: 3 Units :Cell 
Neighborhood statistics: Statistic: Mean Neighborhood: Rectangle Width: 5 Height: 5 Units :Cell 
Neighborhood statistics: Statistic: Mean Neighborhood: Rectangle Width: 7 Height: 7 Units :Cell 
 
 
Rename the in method 1 or method 2 obtained resulting grid to “Relief “ 
Double click the theme and make 7 classes of 0-15; 15-30; 30-50; 50-100; 100-300 and >300 
Choose a dichromatic Color Ramp. 
 

Effect of slope and relief on window size 
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Effects of slope and relief on window size of resp. 3x3, 5x5 and 7x7 
 
 
 

Reclassifying the grids 
 
With the elevation resp. slope and relief theme active: 
Analyses ► Reclassify 
Classify: Number of classes: 6(elevation) resp.  4(slope)  and 6(relief); Round values at : d; OK 
Fill in the Old Values and the New Values (see figure) 
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Elevation (10000-20000 etc.)  Slope (1000-2000 etc)   Relief  (100-200 etc.) 
 

Potential Drainage Density 
 
To obtain the Potential Drainage Density grid the following grids are produced: 
 
From the Elevgrid resp.: ►FlowDirection►FlowAccumalation►Stream►Drain►PDD 
 
Analyses ► Map Calculator: 
[Elevation].Flowdirection(FALSE) 
If TRUE, all cells of the surface will flow away from the surface. 
If FALSE then flow is calculated for cells with the edge being slightly lower than the cell. 
evaluate  
aGrid.FlowDirection request calculates the direction of flow out of each cell into one of its eight 
neighbors. The output is an integer Grid. 
The cell flows to the cell with the lowest elevation. 
The values for each direction from the center are: 
 

 32 64   128 

16 X 1 

8 4 2 

 
X = the processing cell 
 
 

 
78 72 69 71 58 

74 67 56 49 46 

69 53 44 37 38 

64 58 55 22 16 

74 54 34 38 11 

2 2 2 2 4 

2 2 2 4 8 

1 1 2 2 4 

128 2 2 1 4 

1 1 128 1 64 

 
      ⇒ 
 
 
 
 

ElevGrid (with elevation values)    FlowGrid (with direction codes) 
 
Flow Accumulation: 
 
Analyses ► Map Calculator: 
[Flowdirection].Flowaccumulation(NIL) 
If NIL, a weight of 1 is used for each cell. 
Instead of NIL you can use a grid that assigns a weight to each cell 
 
aGrid.FlowAccumulation request creates a Grid of accumulated flow to each cell, by accumulating 
the weight for all cells that flow into each downslope cell. 
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For understanding the procedure ArcView executes: 
With the flowdirection codes in mind add the cells that flow into the other cells for the resulting 
AccumGrid. 
 

    
 
      ⇒ 
 
 
 
 

2 2 2 2 4 

2 2 2 4 8 

1 1 2 2 4 

128 2 2 1 4 

1 1 128 1 64 

0 0 0 0 0 

0 1 1 1 2 

0 3 6 4 0 

0 0 0 8 7 

0 1 3    1 10 

FlowGrid       AcummGrid 
 
StreamGrid = (flowAcc < 100.AsGrid).SetNull(1.AsGrid) 
All cells that have more than 100 cells flowing into them are assigned 1(the pixels which had more 
than 100 km2 catchments area) all other cells are assigned No Data. 
 
DrainGrid=StreamGrid.Focalstats(#Grid_statype_sum,Nbrhood.MakeRectangle(5,5,false),false) 
Summerizes the cells of the StreamGrid in the moving window. 
The Focalsum function is used in the moving window. 
This sum means a simple count of the pixels which represent drainage ways, because these pixels 
have a value of 1. All other pixels value 0. 
The resulting value of the pixels refer to the drainage ways and can have a maximum of 25 (in a 
moving window of 5 x 5). 
 
The resulting “ Potential Drainage Density” Grid file: 
PDDGrid=DrainGrid.IsNull.con(0.AsGrid,DrainGrid) 
“Nodata” will be transferred to 0 
 
The term “drainage density”is not identical to the one used by the geographers and 
geomorphologists. It is not based on the real drainage network. It is derived from a DEM. 
It does not take into consideration the loss of surface water due to infiltration into the soil. 
So the PDD is always >= the real density. 
 
With the pdd theme active: 
Analyses ► Reclassify 
Classify: Number of classes:. 4; Round values at : d; OK 
 
 

 
Combigrid 

 
 
Analyses ► Map Calculator: 
( [Reclass of Slope] + [Reclass of Elevation] + [Reclass of Relief] + [Reclass of PDD]) 
The resulting new grid (combigrid) has combinations with unique values for the combined classes. 
 
With the combigrid theme active: 
Theme ►Convert to Shapefile 
New Shapefile  -- Open Theme Table – Summarize and save as “classtable” 
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Delete the temporary shapefile. 
 
 
 
 
 
 
 
 
 
 
 

 
Building the “Classtable” 

 
Open the classtable in ArcView and start editing. 
Add fields (Edit ►Add fields) resp. “elevation”, “slope”, “relief”, “pdd” and “class” 
as string fields. Fill in the classes of resp. elevation, slope, relief and pdd according the unique code 
It is easy now to query for the several combinations of these parameters in order to analyse and 
finally to fill in the (soter)classification in the “class”field.  
In the script this table will join to the attribute grid file, because this table and the attribute table as 
well have the same unique gridcode field.  

 
 
Join the table to the combigrid and in the Legend Editor of this theme make a legend on this  
 “class” field and save this legend in your working directory as combi.avl 
In the automated process this legend is automatically added to the “combigrid 
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Classifications 
 
Classifications used :  

Elevation Slope Relief PDD 
meter code % code meter code pixel code 

0-200m 10000 0-2 1000 0-15 100 0 1 
200-400m 20000 2-8 2000 15-30 200 1-5 2 
300-400m 30000 8-30 3000 30-50 300 6-15 3 
400-600m 40000 >30 4000 50-100 400 16-25 4 
600-1000m 50000   100-300 500    
1000-1500m 60000   >300 600    
1500-3000m 70000       
>3000m 80000       
 

The automated  process 
Preparing the defaultdem: 
 
Start Arcview  and  under File►Extensions make sure the Spatial Analyst  is loaded. Set the 
Working Directory under File to the desired directory. 
Open a new View and under View►Properties set the Map Units to meters and the Distance Units 
to kilometers. 
Projections Properties ►Category:Projections of a Hemisphere Type:Lambert Equal-Area 
Azimuthal (Equatorial). Select Custum and type +20 for the Central Meridian and +5 for the 
Reference Latitude. 
In the TOC  doubleclick on script and rename the script1 to DEM. 
Paste the avenue text file in this window and compile it. 
With the View active doubleclick on the tool or button bar. 
In the customize dialog window set the type to View and the Category to buttons. 
Click on NEW; doubleclick on “click”and choose DEM from the Script Manager. 
Doubleclick on “Icon” and select an icon in the Icon Manager. 
Save this project file as defaultdem.apr 
This projectfile is the base for your DEM cooking. 
Prior to the DEM cooking put the legend files and the combiclass.dbf in the working directory. 
Set the elevgrid theme active in the active window. 
 
The Avenue script: 
 
' Add several theme's (parameters derived from elevationgrid) 
' and combine it to one grid with the predefined combination classes. J. Huting, dec. 2002 
'******************************************************************************* 
' This script executes with from the DEM derived elevgrid file as inputfile. 
' The particular legends must be predefined as elevation.avl; slope.avl; relief.avl; pdd.avl 
' and combi.avl. and the classcombi.dbf table as well. They have to be placed in the working 
directory. 
' The View window must be the active document with the elevgrid as the active theme. 
'******************************************************************************* 
'set working directory 
                   aFilename="d:\dem".AsFilename 
                   av.GetProject.SetWorkDir(aFilename) 
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                   aFilename.SetCWD 
'select grid theme 
                   theProject=Av.GetProject 
                   theView = Av.GetActiveDoc                  
'check to make sure that there is a theme selected. 
                   if (theView.GetActiveThemes.Count=0) then 
                   Msgbox.Info("Must have a Grid theme selected","") 
                   exit 
                   end 
'get the grid 
                   theGridTheme =theView.GetActiveThemes.Get(0) 
                   elevGrid = theGridTheme.GetGrid 
'real elevation values 
                   elevatigrid=(elevGrid>=32768.AsGrid).con 
                   (elevGrid-65536.AsGrid,elevGrid) 
'eventueel nodata eruit 
                   elevationgrid=(elevatigrid=-9999.AsGrid).setnull(elevatigrid) 
'make elevationgrid 
                   elevationGrid.Rename("Elevation".AsFileName) 
                   elevation=Gtheme.make(elevationGrid) 
                   theView.AddTheme(elevation) 
'calculate slope 
                   slopeAGrid=elevgrid.Slope(2.5,TRUE)                
'the mean value of the slope in the moving window                                                 
slopeGrid=slopeAGrid.Focalstats(#Grid_statype_mean,Nbrhood.MakeRectangle(5,5,false),false) 
'make slope theme in the View 
                   slopeGrid.Rename("Slope".AsFileName) 
                   slope=Gtheme.make(slopeGrid) 
                   theView.AddTheme(Slope) 
'calculate Relief                 
MAXGrid=elevationGrid.Focalstats(#Grid_statype_max,Nbrhood.MakeRectangle(5,5,false),false) 
MINGrid=elevationGrid.Focalstats(#Grid_statype_min,Nbrhood.MakeRectangle(5,5,false),false) 
reliefAGrid=MAXGrid-MINGrid                 
reliefGrid=reliefAGrid.Focalstats(#Grid_statype_mean,Nbrhood.MakeRectangle(5,5,false),false) 
'make relieftheme in the View 
                   ReliefGrid.Rename("Relief".asFileName) 
                   Relief=Gtheme.make(ReliefGrid) 
                   theView.AddTheme(Relief) 
'calculate flow direction 
                   flowDirGrid = elevationGrid.FlowDirection(FALSE) 
'make FlowDir Theme (not added to the View) 
                   flowDirGrid.Rename("FlowDir".asFileName) 
                   flow=GTheme.Make(flowDirGrid) 
'theView.AddTheme(flow)   
'calculate flow accumulation 
                   flowAccGrid = flowDirGrid.FlowAccumulation(NIL) 
'make FlowCum Theme (not added to the View) 
                  flowAccGrid.Rename("FlowCum".asFileName) 
                  flow=GTheme.Make(flowAccGrid) 
'theView.AddTheme(Flow) 
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'extract streams from flow accumulation 
                  streamGrid = (flowAccGrid<100.AsGrid).SetNull(1.AsGrid)     
'summerize the cells of the streamgrid in the moving window                  
DrainGrid=streamgrid.Focalstats(#Grid_statype_sum,Nbrhood.MakeRectangle(5,5,false),false) 
'the Nodata will be transferred to the value 0 
                   PDDGrid=DrainGrid.IsNull.con(0.AsGrid,DrainGrid) 
'make PDD Theme in the View 
                   PDDGrid.Rename("PDD".asFileName) 
                   PDD=Gtheme.Make(PDDGrid) 
                   theView.AddTheme(PDD) 
'OPTIONAL 
'delineate stream links 
'streamLinkGrid = streamGrid.StreamLink(flowDirGrid) 
'delineate watersheds for each stream link 
'watershedGrid = flowDirGrid.Watershed(streamLinkGrid) 
'make Watershd Theme in View 
'watershedGrid.Rename("Watershd".AsFileName) 
'watershed=GTheme.make(watershedGrid) 
'theView.AddTheme(watershed) 
 
'SET THE LEGENDS 
'to identify 
                  theView=av.GetActiveDoc 
                  for each T in theView.GetActiveThemes 
                  theView = av.GetActiveDoc 
                  for each t in theView.GetThemes 
                  if (t.IsVisible.not) then t.SetVisible(FALSE) 
                  end 
                  theSourceName=T.GetSrcName 
                  theFileName=theSourceName.GetFileName 
                  theThemeLegend=T.GetLegend 
                  theFileString=theFileName.GetFullName 
                  theFileStringLength=theFileString.Count 
'Determine the name of the legend file 
                  if(theFileString.Middle((theFileStringLength-4),1)="")then 
                  theLegendString=(theFileString.Left(theFileStringLength-4))+".avl" 
                  theLegendFile=theLegendString.AsFileName 
                  else 
                  theLegendString=theFileString+".avl" 
                  theLegendFile=theLegendString.AsFileName 
                  end 
'Load the legend 
                  if(File.Exists(theLegendFile))then 
                  theThemeLegend.Load(theLegendFile,#LEGEND_LOADTYPE_ALL) 
                  T.InvalidateLegend 
                  else 
                  MsgBox.Info("Sorry"++theFileString++"has no locallegend","Missing avl....") 
                  end end end                        
'making the reclassify gridthemes (not added to the View) 
                  theView=av.GetActiveDoc 
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                  theTheme=elevation 
                  theLegend=theTheme.GetLegend 
                  theGrid=theTheme.GetGrid 
                  theFldName=theLegend.GetFieldNames.Get(theLegend.GetFieldNames.Count-1) 
                  aClassList=theLegend.GetClassifications 
                  theClassList=aClassList.DeepClone 
                  count=10000 
                  for each c in theClassList 
                  c.SetLabel(count.AsString) 
                  count=count+10000 
                  end 
                  ElevationGrid = theGrid.ReclassByClassList(theFldName,theClassList,FALSE) 
                  ElevationGrid.Rename("Recelev".AsFileName) 
                  Recelev=Gtheme.Make(ElevationGrid) 
'theView.AddTheme(Recelev) 
                  theTheme=slope 
                  theLegend=theTheme.GetLegend 
                  theGrid=theTheme.GetGrid 
                  theFldName=theLegend.GetFieldNames.Get(theLegend.GetFieldNames.Count-1) 
                  aClassList=theLegend.GetClassifications 
                  theClassList=aClassList.DeepClone 
                  count=1000 
                  for each c in theClassList 
                  c.SetLabel(count.AsString) 
                  count=count+1000 
                  end 
                  SlopeGrid = theGrid.ReclassByClassList(theFldName,theClassList,FALSE) 
                  SlopeGrid.Rename("Recslope".AsFileName) 
                  Recslope=Gtheme.Make(SlopeGrid) 
'theView.AddTheme(Recslope) 
                  theTheme=Relief 
                  theLegend=theTheme.GetLegend 
                  theGrid=theTheme.GetGrid 
                  theFldName=theLegend.GetFieldNames.Get(theLegend.GetFieldNames.Count-1) 
                  aClassList=theLegend.GetClassifications 
                  theClassList=aClassList.DeepClone 
                  count=100 
                  for each c in theClassList 
                  c.SetLabel(count.AsString) 
                  count=count+100 
                  end 
                  ReliefGrid=theGrid.ReclassByClassList(theFldName,theClassList,FALSE) 
                  ReliefGrid.Rename("Recrelief".AsFileName) 
                  Recrelief=Gtheme.Make(ReliefGrid) 
'theView.AddTheme(Recrelief) 
                  theTheme=PDD 
                  theLegend=theTheme.GetLegend 
                  theGrid=theTheme.GetGrid 
                  theFldName=theLegend.GetFieldNames.Get(theLegend.GetFieldNames.Count-1) 
                  aClassList=theLegend.GetClassifications 
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                  theClassList=aClassList.DeepClone 
                  count=1 
                  for each c in theClassList 
                  c.SetLabel(count.AsString) 
                  count=count+1 
                  end 
                  PDDGrid = theGrid.ReclassByClassList(theFldName,theClassList,FALSE) 
                  PDDGrid.Rename("Recpdd".AsFileName) 
                  Recpdd=Gtheme.Make(PDDGrid) 
'theView.AddTheme(Recpdd) 
'combination reclass grids van elevation, slope, relief and pdd 
                  combiGrid=ElevationGrid+ReliefGrid+SlopeGrid+PDDGrid 
'make combi theme in View 
                  CombiGrid.Rename("Combi".asFileName) 
                  Combi=Gtheme.Make(CombiGrid) 
                  theView.AddTheme(Combi) 
'retrieving the classcombi.dbf from the working directory   
       theView=theProject.FindDoc(“View1”) 
       theTheme=theView.FindTheme(“combi”) 
                  patterns = {"*.dbf", "arcdr9", "*.txt"} 
                  labels = {"dBASE (*.dbf)", "INFO", "Delimited Text (*.txt)"} 
                  files = FileDialog.ReturnFiles(patterns, labels, "Add Table", 0) 
                  for each f in files 
                  v = VTab.Make(f, FALSE, FALSE) 
                  if (v.HasError) then 
                  if (v.HasLockError) then 
                  MsgBox.Error("Unable to acquire Read Lock for file " + f.GetBaseName, "") 
                  else 
                  MsgBox.Error("The file '" + f.GetBaseName + "' is not valid.", "") 
                  end 
                  else 
                  gui = av.GetProject.GetSelectedGUI 
                  if (gui.GetType <> "Table") then 
                 GUIName = "Table" 
                 else 
                 GUIName = gui.GetName 
                 end      
                 t = Table.MakeWithGUI(v, GUIName) 
                 t.SetName(v.GetName) 
                 t.GetWin.Open 
                 end 
                 end  
'joining the classcombi table to the "combi" attribute table 
      theView=theProject.FindDoc("View1" 
      theGridTheme=theView.FindTheme("elevgrid") 

     elevgrid=theGridTheme.GetGrid 
     theGridTheme.SetActive(FALSE) 
     theGridTheme.SetVisible(FALSE) 
     theGridTheme=theView.FindTheme("combi") 
     combi = theGridTheme.GetGrid 
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     theGridTheme.SetActive(TRUE) 
     theGridTheme.SetVisible(TRUE) 

                 Tab2=av.Getproject.FindDoc("classcombi.dbf") 
                 Tab2 = av.GetActiveDoc 
                 VTab2=Tab2.GetVTab 
                 field2=VTab2.FindField("Gridcode") 
                 theView=av.GetProject.FindDoc("Combi") 
                 combiFTab=combi.getVTab 
                 field1=combiFTab.FindField("Value") 
                 CombiFTab.Join(field1,VTab2,field2) 
'making the theme the first in the TOC 
      theView=theProject.FindDoc("View1" 
                 theThemeList=theView.GetThemes 
                 theThemeList.Shuffle(theThemeList.Get(0),(theThemeList.Count)) 
                 theThemeList.Get(theThemeList.Count-1).SetActive(TRUE) 
                 theView.InvalidateTOC(nil) 
                 theView.GetDisplay.Invalidate(true) 
'retrieving the legend of the combi grid from the working directory 
                 theGridTheme =theView.GetActiveThemes.Get(0) 
                 combi = theGridTheme.GetGrid 
                 theGridTheme.setactive(TRUE) 
                 theTheme = theView.GetActiveThemes.Get(0) 
                 theLegendFile="combi.avl".AsFileName 
                 theThemeLegend = theTheme.GetLegend 
                 theThemeLegend.Load(theLegendFile,#LEGEND_LOADTYPE_ALL) 
                 TheGridTheme.InvalidateLegend 
 
Optional: 
To prevent the projectfile to be saved as demfault.apr you can append the system script 
“Project.Save as” (you can find this script in the scripteditor under Script►Load System Script) 
to the DEM script. 
 
 
Running the script: 
 
Open the defaultdem.apr in ArcView, retrieve your elevgrid and make it active. 
Click on the DEM button. 
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Short description of the script: 
 
In the View the script is generating respectively: 
 
1. Elevation  The real elevation values are produced 

No data is removed 
2. Slope  (In %, multiplied with factor 2.5) 

INRA (Institute National de la Recherche Agronomique France) has compared the % 
slope in a 1 km DEM with % slope in high resolution DEMs and found this empirical 
factor 2.5. Probably this factor is not the same as for Zimbabwe, but due to the lack 
of high resolution DEM’s for Zimbabwe we adopted this one.  

  The mean of the result is calculated in a 5 x 5 window 
3. Relief Maximum minus Minimum elevation in a 5 x 5 moving window. 
  The mean of the result is calculated in the moving window. 
4. PDD  

a. Flowdirection 
b. Flowaccumulation 
c. Streamgrid  
d. Draingrid 
e  FocalSUM in a 5 x 5 moving window 
f. PDD = The draingrid, but “Nodata” is set to 0 

 
5. Legends 

The legends are retrieved from the working directory. 
(The legend name is the same as the theme name) 
 

6. Reclassify 
The script generates the reclassify grids for the 4 themes. 
 

7. Combigrid 
The grids are combined to 1 grid: the combigrid 

 
8. Combiclass table 

The combiclass table is retrieved from the working directory and joined to the 
combigrid attribute table. 

 
9. Legend combigrid 

 
Set the combigrid active and visible as the first theme in the Table of Contents 

  retrievs the legend for the combigrid. 
 
10. Save the project 
  The script asks for a name.  
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Hierarchy of major landforms according Soter manual 

 
        % slope relief 
 
L level land   LP plain    <8  <100m/km 
   LL plateau    <8  <100m/km 
    LD depression    <8  <100m/km 
   LF low-gradient footslope  <8  <100m/km 
   LV valley floor   <8  <100m/km 
 
S sloping land  SM medium-gradient mountain 15-30  >300m/km 
   SH medium-gradient hill  8-30  >50m/km 
   SE medium-gradient esc.zone 15-30  <300m/km 
   SR ridges    8-30  >50m/km 
   SU mountainous highland  8-30  >300m/km 
   SP dissected plain   8-30  <50m/km 
 
T steep land  TM high-gradient mountain  >30  >300m/km 
   TH high-gradient hill   >30  <300m/km 
   TE high-gradient esc. zone  >30  >300m/km 
   TV high gradient valleys  >30  >300m/km 
 
C land with composite 
    landforms  CV valley    >8  variable 
   CL narrow plateau   >8  variable 
   CD major depression   >8  variable 
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Discussion 
 
 
A basic understanding of the terrain is necessary in order to adjust the moving window size. 
This is accomplished by examining the pre-existing SOTER “expert” landform map. 
The DEM resolution also plays a roll in determining the window size. In this study case a DEM 
with a 1 km resolution and window size of 5 x 5 may be appropriate for the analysis. 
It is important to note that the window size will affect the slope and especially the relief component. 
The resulting map contain many classes, which can be grouped based on topographic similarities. 
Generalizing the classes can be used to derive general terrain patterns. 
Viewing these patterns can aid in deciding a further breakdown in classes if necessary. 
The user must understand the characteristics of the DEM and the size of the terrain features in order 
to select window size and to make decisions for generalizing the classes. 
 
Comparing the landform “expert” map( see map 1)  with the resulting combigrid map (see map 2) 
you can notice the unclassified mountainous area in the south on map 1. 
Also comparing the other classified terrain units on map 1 with map 2 you can notice the 
differences. Looking at map 3 you can clearly see the part of the depression of Botswana in 
Zimbabwe’s area. 
 
 
 

Conclusion 
 
A 1 km resolution DEM has been used to derive terrain classes for the development of SOTER map 
units. The procedure here is based on measurements which are repeatable. 
In fact the application can be used on any part of the world. 
GTOPO30 DEMs are available for free and can be processed for all these areas on the Earth. 
Terrain classes can be obtained using the elevation and derivatives as presented here, but some 
(sub) classes, especially in the level land cannot be distinguished as those defined in the SOTER 
procedures manual.  
However, it is strongly recommended to use higher resolution DEMs. 
Higher resolution DEM data will be increasingly available world wide. 
In February, 2000 there was a U.S. Shuttle Radar Topographic mission that collected data for 80% 
of the Earth’s land surface using radar interferometry. These data with a 30 m resolution will be 
available in the next 2 or 3 years. Future initiatives need to examine these DEM data and to derive 
or enhance terrain classes for the SOTER database. 
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Slope thresholds, based on a GTOPO30 1km resolution DEM and a window size of 5 x 5  
in combination with the elevation classes. 
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PDD thresholds, based on a GTOPO30 1 km resolution DEM and a window size of 5 x 5 
in combination with a slope threshold of 0-8%  and the elevation classes. 
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Relief thresholds, based on a GTOPO30 1 km resolution DEM and a window size of 5 x 5 
in combination with the elevation classes. 
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